2009/03/23

在 BSD 灌 firefox 奮戰筆記

問題:
> cd /usr/pkgsrc/www/firefox
> make install
=> Required installed package digest>=20010302: digest-20060826 found
===> Checking for vulnerabilities in firefox-1.5.0.9
ERROR: remote-information-exposure vulnerability in firefox-1.5.0.9 - see http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2894 for more information
firefox{,-bin,-gtk1}<2.0.0.8>
......
ERROR: Define ALLOW_VULNERABLE_PACKAGES if this package is absolutely essential
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/www/firefox

解釋:firefox 灌不起來

電腦系統:NetBSD

解決辦法:修改 Makefile

> vi Makefile
最後加上一行
ALLOW_VULNERABLE_PACKAGES=YES
儲存離開,然後

> make install

OK!開始灌了!不過要灌很久就是了......





參考資料:
1. Subject: Re: 'define ALLOW_VULNERABLE_PACKAGES'
2. Re: README.html: cannot find vulnerability list

No comments:

Post a Comment

##EasyReadMore##

被我監控的 Blog